题 如何使--no-ri --no-rdoc成为gem install的默认设置?


我不使用我在我的机器或我处理的服务器中安装的gems的RI或RDoc输出(我使用其他文档方法)。

我安装的每个gem默认安装RI和RDoc文档,因为我忘了设置 --no-ri --no-rdoc

有没有办法让这两个标志成为默认值?


963
2017-09-04 21:48


起源


但这不是一个好主意。我最近需要在路上和我发布时编写代码 gem server 我记得我有这些 $HOME/.gemrc 真的杀了我......谷歌并不总是在那里。 - Panagiotis Atmatzidis
取决于具体情况。如果您可以在不需要gem文档的服务器上进行连接或者这样做,这是一个好主意。 - sir-pinecone
用撬可以使用 show-source 作为生成的文档的替代。它将显示内联注释,这些注释通常与ri / rdoc的内容相同。 - max pleaner


答案:


您只需将以下行添加到您的本地 ~/.gemrc 文件(它在你的  夹)

gem: --no-document

或者您可以将此行添加到全局gemrc配置文件中。以下是如何找到它(在Linux中)

strace gem source 2>&1 | grep gemrc

1120
2017-09-06 16:10



在这里你去/ etc / gemrc - Jirapong
/ etc / gemrc对我不起作用,但是.gemrc做了。我想知道它是否特定rvm它不读取系统gemrc? - wjl
虽然这有效, stackoverflow.com/a/7662245/550672 是正确的 - Zeophlite
@ gdelfino的回答是最不突兀的 - Ryan
弃用 - 请看我的答案 - James Lim


RVM的文档

只需将此行添加到您的 ~/.gemrc 要么 /etc/gemrc

gem: --no-rdoc --no-ri 

注意: 最初的答案是:

install: --no-rdoc --no-ri 
update: --no-rdoc --no-ri 

这不再有效; RVM文档已经更新,因此目前的答案只包括 gem 指令是正确的。


473
2017-10-05 13:44



虽然原作,这是正确的方式... - mik
自RubyGems版本2.0.0preview2,你可以改用 --no-document 要么 --document=rdoc 对于rdoc。 - iono
我不同意2013年6月20日@ mpapis的编辑。他完全改变了这个答案,有很多人投票支持它,因为他们认为这比接受的答案要好。发布此答案的人明确写道,他们不希望将这两个选项添加到每个gem命令,因为它会破坏一些命令。在@mpapis完全改变答案之前,答案中的代码是: install: --no-rdoc --no-ri\nupdate: --no-rdoc --no-ri   @mpapis,为什么要更改RVM文档并更改此答案? - David Grayson
因为它是真的,没有理由保留两个单独的行,跟踪多项目兼容性是棘手的 - 当我们发现某些东西关闭时RVM文档有时会更新 - 就像在这种情况下,rubygems不是真的表现不对,使用起来都很好 gem: 而不是两个单独的条目。 - mpapis
使用 ruby -e "require 'etc';puts Etc.sysconfdir" 确定你的路径 gemrc 配置文件。 - Michael Mims


注意 --no-ri 和 --no-rdoc 根据新的不推荐使用 导游。推荐的方法是使用 --no-document 在 ~/.gemrc 要么 /etc/gemrc

install: --no-document
update: --no-document

要么

gem: --no-document

161
2018-06-19 21:02





在Linux(可能还有Mac)上:

echo 'gem: --no-document' >> ~/.gemrc

这个单线曾经在这里发表评论,但不知何故消失了。


70
2017-09-18 07:06



你应该用 >> 如果用户已经拥有 ~/.gemrc。 - nickgrim
这有什么不同吗? echo 'gem: --no-doc --no-ri' >> ~/.gemrc 你写的那个或者两个都有同样的效果? - Lykos
@Lykos --no-doc --no-ri 已弃用(请参阅 guides.rubygems.org/command-reference/#gem_install 选项) - Slava V


#/home/{user}/.gemrc

---
:update_sources: true
:sources:
- http://gems.rubyforge.org/
- http://gems.github.com
:benchmark: false
:bulk_threshold: 1000
:backtrace: false
:verbose: true
gem: --no-ri --no-rdoc

http://webonrails.com/2008/12/03/skiping-installation-of-ri-and-rdoc-documentation-while-installing-gems/


42
2018-06-28 19:15



感谢这个例子,非常适合帮我删除我在某些时候复制和粘贴的嵌入式Ruby,然后在Ruby 1.9.2下安装RubyGems 1.8.10时导致精神错误。 - stevenhaddox
请不要发布“Google上的第一个结果”回复。 Google上的第一个结果现在显示您的回复,自我证明您不应该这样做的原因。谢谢,当然,谢谢你的回答。 - wjl
实际上,“谷歌的第一个结果”显示:“”谷歌的第一个结果“显示:”“谷歌的第一个结果”显示:“”......错误:堆栈溢出。 - Félix Saparelli
我要感谢史蒂夫的评论(上图)。为什么我无法安装最新的RubyGems,我正在拔头发。事实证明我也有一个格式错误的.gemrc文件。我一直收到这个错误:../。rbenv /versions / 1.9.2-p290 / lib / ruby​​ / 1.9.1 / psych.rb:148:'解析':无法在第2行第10列解析YAML(迷幻:: SyntaxError错误) - wchrisjohnson


在Windows XP上,.gemrc文件的路径是

c:\Documents and Settings\All Users\Application Data\gemrc 

并且默认情况下不会创建此文件,您应该自己创建它。


31
2017-09-12 05:28



在Windows 7下,它是C:\ ProgramData \ gemrc - Viachaslau Tysianchuk
win7位置适用于Windows 200.还要确保你有“隐藏已知文件类型的扩展名”,它不会选择gemrc.txt .... facepalm - jtzero


适用于Windows 7用户的oneliner:

(echo install: --no-document && echo update: --no-document) >> c:\ProgramData\gemrc


15
2017-09-05 00:23